JetBrains 授权服务器

如果授权失败请翻到底部查看更新与维护!

如果授权失败请翻到底部查看更新与维护!

如果授权失败请翻到底部查看更新与维护!


借助 ilanyu’s Blog 公开的技术搭建的 JetBrains 授权服务器,狼煞博客未参与任何破解工作。

理论上可授权 JetBrains 旗下的所有产品,已经确认支持下列产品:

  • IntelliJ IDEA 7.0 或更高
  • ReSharper 3.1 或更高
  • ReSharper Cpp 1.0 或更高
  • dotTrace 5.5 或更高
  • dotMemory 4.0 或更高
  • dotCover 1.0 或更高
  • RubyMine 1.0 或更高
  • PyCharm 1.0 或更高
  • WebStorm 1.0 或更高
  • PhpStorm 1.0 或更高
  • AppCode 1.0 或更高
  • CLion 1.0 或更高

授权服务器地址:

http://jetbrains.wolfogre.com

使用方法如图:

image

此外,我在已有的破解程序上添加了一个代理层,见 jetbrains-licenser-proxy,实现了一些附加的功能:

需要强调的是,狼煞博客仅为编程爱好者提供授权服务,若将 JetBrains 产品用于商业开发,请务必购买正版

若因授权而引起任何的法律纠纷,狼煞博客概不负责。


更新与维护

2018.07.18

目前使用的授权工具版本为 v1.3,在授权 IntelliJ IDEA Ultimate 2018.1.5、GoLand 2018.1.5 等新版本产品时会提示“Outdated License Server Detected”。

ilanyu’s Blog 提供的最新版本的 v1.6 仍然存在这个问题。

故目前尚没有解决方案,无视提示即可。

2018.08.02

根据 JetBrains 官方的通告,新产品将逐步弃用旧版的 license server,具体措施为:

  • JetBrains IDEs 收费产品:
    1. 版本低于 2018.1:可以正常使用;
    2. 版本高于等于 2018.1,低于 2018.2.1:可以正常使用但警告“Outdated License Server Detected”;
    3. 版本高于等于 2018.2.1:无法正常使用。
  • .NET tools 收费产品:
    1. 版本低于 2018.2:可以正常使用;
    2. 版本高于等于 2018.2,低于 2018.3:可以正常使用但警告“Outdated License Server Detected”;
    3. 版本高于等于 2018.3:无法正常使用。

目前 JetBrains 的收费产品的最新版本大都为 2018.2,已是在危险的边缘。目前还有没升级 license server 的方案,只能在新方案出现之前,慎重选择升级。

2018.08.13

陆陆续续有无法授权的新版本发布了,已有小伙伴中招。

目前的对应策略仍然是:新用户请安装老版本,老用户请谨慎升级。

2018.08.27

目前能正常破解的最高版本为 2018.2,我整理了一下各产品的 2018.2 版的下载地址,见《JetBrains IDE 2018.2 下载地址整理》

2018.09.13

Rover12421 提供了一种替换 IDE 的执行文件来破解授权检查的方法,目前其最新版的工具 JetbrainsCrack 3.1 被证实能破解 2018.2.1 版的 IntelliJ IDEA、DataGrip、PyCharm,但似乎不支持其他 IDE,比如 WebStorm、Goland 等。